{"action":"Upgrade libgit2 to 0.27.3-r0 or later.","affected":[{"fixed":"0.27.3-r0","introduced":"0"}],"component":"libgit2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.8","exploited":false,"fixed_versions":["0.27.3-r0"],"id":"tcs_01M5NA2MXTK1VWEHTX9N34BJFE","modified_at":"2026-10-23T17:23:46.269309410Z","published_at":"2018-07-10T14:29:00.323Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-10888","https://security.alpinelinux.org/vuln/CVE-2018-10888"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-10888#Alpine:v3.8/libgit2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-10888"}],"summary":"A flaw was found in libgit2 before version 0.27.3. A missing check in git_delta_apply function in delta.c file, may lead to an out-of-bound read while reading a binary delta file. An attacker may use"}