{"action":"Upgrade rails to 2.3.14.1 or later.","affected":[{"fixed":"2.3.14.1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.3.14.1"],"id":"tcs_01M5NA36P7TN57TAN7JWJS5F1C","modified_at":"2026-10-23T17:47:31.688598163Z","published_at":"2012-08-10T10:34:47.890Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-3464","https://security-tracker.debian.org/tracker/CVE-2012-3464"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-3464#Debian:14/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-3464"}],"summary":"Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow rem"}