{"action":"Upgrade redis to 3.2.12-r0 or later.","affected":[{"introduced":"4.0"}],"component":"redis","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.5","exploited":false,"fixed_versions":["3.2.12-r0"],"id":"tcs_01M5NA3R4DWPV53ZP49Y01RR9T","modified_at":"2026-10-23T17:17:55.203480705Z","published_at":"2018-06-17T17:29:00.277Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-11218","https://security.alpinelinux.org/vuln/CVE-2018-11218"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-11218","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-11218"}],"summary":"Memory Corruption was discovered in the cmsgpack library in the Lua subsystem in Redis before 3.2.12, 4.x before 4.0.10, and 5.x before 5.0 RC2 because of stack-based buffer overflows."}