{"action":"Upgrade puppet to 2.7.18-1 or later.","affected":[{"fixed":"2.7.18-1","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.18-1"],"id":"tcs_01M5NA3RKKWR9DYCKXV04FK8BQ","modified_at":"2026-08-19T06:47:36.171978915Z","published_at":"2012-08-06T16:55:06.367Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-3866","https://security-tracker.debian.org/tracker/CVE-2012-3866"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-3866","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-3866"}],"summary":"lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml, which allows local users to obtain sensitive configuration inf"}