{"action":"Upgrade fwknop to 2.0.3-1 or later.","affected":[{"fixed":"2.0.3-1","introduced":"0"}],"component":"fwknop","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.0.3-1"],"id":"tcs_01M5NA4GDPB6YYF82FTJJM26KF","modified_at":"2026-10-23T17:47:40.570274932Z","published_at":"2012-10-22T23:55:07.070Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-4435","https://security-tracker.debian.org/tracker/CVE-2012-4435"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-4435","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-4435"}],"summary":"fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated users to cause a denial of service (server crash) via a long IP address."}