{"action":"Upgrade cups-pk-helper to 0.2.3-1 or later.","affected":[{"fixed":"0.2.3-1","introduced":"0"}],"component":"cups-pk-helper","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.2.3-1"],"id":"tcs_01M5NA4SWBGJ0N1SPTRHEGTM3N","modified_at":"2026-10-23T17:47:30.978549507Z","published_at":"2012-11-20T00:55:01.057Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-4510","https://security-tracker.debian.org/tracker/CVE-2012-4510"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-4510","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-4510"}],"summary":"cups-pk-helper before 0.2.3 does not properly wrap the (1) cupsGetFile and (2) cupsPutFile function calls, which allows user-assisted remote attackers to read or overwrite sensitive files using CUPS r"}