{"action":"Upgrade perl to 5.14.2-14 or later.","affected":[{"fixed":"5.14.2-14","introduced":"0"}],"component":"perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.14.2-14"],"id":"tcs_01M5NA5H8HA3926NH07Z994VBE","modified_at":"2026-10-23T17:47:45.845219490Z","published_at":"2012-12-18T00:55:01.587Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-5195","https://security-tracker.debian.org/tracker/CVE-2012-5195"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-5195#Debian:13/perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-5195"}],"summary":"Heap-based buffer overflow in the Perl_repeatcpy function in util.c in Perl 5.12.x before 5.12.5, 5.14.x before 5.14.3, and 5.15.x before 15.15.5 allows context-dependent attackers to cause a denial o"}