{"action":"Upgrade weechat to 0.3.9.1-1 or later.","affected":[{"fixed":"0.3.9.1-1","introduced":"0"}],"component":"weechat","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.3.9.1-1"],"id":"tcs_01M5NA6EBZJAEWJXDV009QT516","modified_at":"2026-10-23T17:47:23.940313126Z","published_at":"2012-11-19T12:10:54.417Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-5854","https://security-tracker.debian.org/tracker/CVE-2012-5854"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-5854#Debian:14/weechat","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-5854"}],"summary":"Heap-based buffer overflow in WeeChat 0.3.6 through 0.3.9 allows remote attackers to cause a denial of service (crash or hang) and possibly execute arbitrary code via crafted IRC colors that are not p"}