{"action":"Upgrade ruby-rack to 1.4.1-2.1 or later.","affected":[{"fixed":"1.4.1-2.1","introduced":"0"}],"component":"ruby-rack","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.4.1-2.1"],"id":"tcs_01M5NA6YYN6SSF41K0VY77ZYBM","modified_at":"2026-10-23T17:47:22.886505678Z","published_at":"2013-03-01T05:40:16.863Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-6109","https://security-tracker.debian.org/tracker/CVE-2012-6109"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-6109#Debian:13/ruby-rack","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-6109"}],"summary":"lib/rack/multipart.rb in Rack before 1.1.4, 1.2.x before 1.2.6, 1.3.x before 1.3.7, and 1.4.x before 1.4.2 uses an incorrect regular expression, which allows remote attackers to cause a denial of serv"}