{"action":"Upgrade openconnect to 3.20-3 or later.","affected":[{"fixed":"3.20-3","introduced":"0"}],"component":"openconnect","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.20-3"],"id":"tcs_01M5NA73EJPJAXAPVF2Y8NT98B","modified_at":"2026-10-23T17:47:41.287572166Z","published_at":"2013-02-24T19:55:01.017Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-6128","https://security-tracker.debian.org/tracker/CVE-2012-6128"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-6128#Debian:14/openconnect","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-6128"}],"summary":"Multiple stack-based buffer overflows in http.c in OpenConnect before 4.08 allow remote VPN gateways to cause a denial of service (application crash) via a long (1) hostname, (2) path, or (3) cookie l"}