{"action":"Upgrade inspircd to 2.0.16-1 or later.","affected":[{"fixed":"2.0.16-1","introduced":"0"}],"component":"inspircd","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.0.16-1"],"id":"tcs_01M5NA7TKNTKFJ706JYE2PR3FB","modified_at":"2026-10-23T18:02:28.872975561Z","published_at":"2017-09-25T21:29:00.257Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-6696","https://security-tracker.debian.org/tracker/CVE-2012-6696"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-6696","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-6696"}],"summary":"inspircd in Debian before 2.0.7 does not properly handle unsigned integers. NOTE: This vulnerability exists because of an incomplete fix to CVE-2012-1836."}