{"action":"Upgrade bash to 4.3-1 or later.","affected":[{"fixed":"4.3-1","introduced":"0"}],"component":"bash","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.3-1"],"id":"tcs_01M5NA80N1CXJADGER4Q6FEF5F","modified_at":"2026-10-23T18:02:55.019123786Z","published_at":"2019-06-18T18:15:09.247Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-6711","https://security-tracker.debian.org/tracker/CVE-2012-6711"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-6711","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-6711"}],"summary":"A heap-based buffer overflow exists in GNU Bash before 4.3 when wide characters, not supported by the current locale set in the LC_CTYPE environment variable, are printed through the echo built-in fun"}