{"action":"Upgrade puppet to 2.7.18-3 or later.","affected":[{"fixed":"2.7.18-3","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.18-3"],"id":"tcs_01M5NAAKJQA38HBB0JDB79X4T6","modified_at":"2026-08-04T06:03:35.596608971Z","published_at":"2013-03-20T16:55:01.807Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2013-1655","https://security-tracker.debian.org/tracker/CVE-2013-1655"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2013-1655","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2013-1655"}],"summary":"Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to \"serialized attributes.\""}