{"action":"Upgrade strongswan to 4.3.4-1 or later.","affected":[{"fixed":"4.3.4-1","introduced":"0"}],"component":"strongswan","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.3.4-1"],"id":"tcs_01M5NACHRY08V9M7DA3MJW465C","modified_at":"2026-09-01T20:03:15.403131149Z","published_at":"2013-07-09T17:55:01.060Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2013-2054","https://security-tracker.debian.org/tracker/CVE-2013-2054"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2013-2054","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2013-2054"}],"summary":"Buffer overflow in the atodn function in strongSwan 2.0.0 through 4.3.4, when Opportunistic Encryption is enabled and an RSA key is being used, allows remote attackers to cause a denial of service (pl"}