{"action":"Upgrade libgit2 to 0.27.4-r0 or later.","affected":[{"fixed":"0.27.4-r0","introduced":"0.27.0"}],"component":"libgit2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.9","exploited":false,"fixed_versions":["0.27.4-r0"],"id":"tcs_01M5NACKV4SAQ9765MMQYGPEY5","modified_at":"2026-10-23T17:17:55.221001966Z","published_at":"2018-08-18T02:29:01.713Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-15501","https://security.alpinelinux.org/vuln/CVE-2018-15501"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-15501#Alpine:v3.9/libgit2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-15501"}],"summary":"In ng_pkt in transports/smart_pkt.c in libgit2 before 0.26.6 and 0.27.x before 0.27.4, a remote attacker can send a crafted smart-protocol \"ng\" packet that lacks a '\\0' byte to trigger an out-of-bound"}