{"action":"Upgrade curl to 7.31.0-1 or later.","affected":[{"fixed":"7.31.0-1","introduced":"0"}],"component":"curl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["7.31.0-1"],"id":"tcs_01M5NADA03E5B27C7GVY0MSS1H","modified_at":"2026-09-01T20:03:15.795488Z","published_at":"2013-07-31T13:20:25.267Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2013-2174","https://security-tracker.debian.org/tracker/CVE-2013-2174"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2013-2174#Debian:13/curl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2013-2174"}],"summary":"Heap-based buffer overflow in the curl_easy_unescape function in lib/escape.c in cURL and libcurl 7.7 through 7.30.0 allows remote attackers to cause a denial of service (application crash) or possibl"}