{"action":"Upgrade postgresql to 11.1-r0 or later.","affected":[{"fixed":"11.1-r0","introduced":"10.0"}],"component":"postgresql","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.12","exploited":false,"fixed_versions":["11.1-r0"],"id":"tcs_01M5NAFZT77FX169CJ9G48NGW9","modified_at":"2026-11-03T06:31:20.489952911Z","published_at":"2018-11-13T15:29:00.233Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-16850","https://security.alpinelinux.org/vuln/CVE-2018-16850"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-16850#Alpine:v3.12/postgresql","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-16850"}],"summary":"postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can caus"}