{"action":"Upgrade postgresql14 to 11.1-r0 or later.","affected":[{"fixed":"11.1-r0","introduced":"0"}],"component":"postgresql14","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.18","exploited":false,"fixed_versions":["11.1-r0"],"id":"tcs_01M5NAG16FDH77XFH0AC4RG2ZA","modified_at":"2026-10-23T17:17:55.228856231Z","published_at":"2018-11-13T15:29:00.233Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-16850","https://security.alpinelinux.org/vuln/CVE-2018-16850"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-16850#Alpine:v3.18/postgresql14","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-16850"}],"summary":"postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can caus"}