{"action":"Upgrade rubygems to 3.2.0~rc.1-1 or later.","affected":[{"fixed":"3.2.0~rc.1-1","introduced":"0"}],"component":"rubygems","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.2.0~rc.1-1"],"id":"tcs_01M5NAG6MH04AQ7KDXMNWAV889","modified_at":"2026-09-01T20:03:17.948928039Z","published_at":"2013-10-17T23:55:04.407Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2013-4287","https://security-tracker.debian.org/tracker/CVE-2013-4287"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2013-4287#Debian:14/rubygems","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2013-4287"}],"summary":"Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used"}