{"action":"Upgrade perl to 5.26.3-r0 or later.","affected":[{"fixed":"5.26.3-r0","introduced":"0"}],"component":"perl","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["5.26.3-r0"],"id":"tcs_01M5NAJ7D1TNGHX95ATDX8PM20","modified_at":"2026-10-23T17:17:55.233556860Z","published_at":"2018-12-07T21:29:00.920Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-18314","https://security.alpinelinux.org/vuln/CVE-2018-18314"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-18314#Alpine:v3.24/perl","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-18314"}],"summary":"Perl before 5.26.3 has a buffer overflow via a crafted regular expression that triggers invalid write operations."}