{"action":"Upgrade hplip to 3.13.11-2 or later.","affected":[{"fixed":"3.13.11-2","introduced":"0"}],"component":"hplip","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.13.11-2"],"id":"tcs_01M5NAKH0HMG3NXSXPF9TJ9ARM","modified_at":"2026-09-01T20:03:19.059770700Z","published_at":"2013-12-09T18:55:10.327Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2013-6427","https://security-tracker.debian.org/tracker/CVE-2013-6427"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2013-6427#Debian:14/hplip","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2013-6427"}],"summary":"upgrade.py in the hp-upgrade service in HP Linux Imaging and Printing (HPLIP) 3.x through 3.13.11 launches a program from an http URL, which allows man-in-the-middle attackers to execute arbitrary cod"}