{"action":"Upgrade ruby-will-paginate to 3.0.5-1 or later.","affected":[{"fixed":"3.0.5-1","introduced":"0"}],"component":"ruby-will-paginate","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.0.5-1"],"id":"tcs_01M5NAKRD3D0VT80PA5N2QFE8Y","modified_at":"2026-09-01T20:02:14.883178231Z","published_at":"2013-12-31T16:04:23.447Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2013-6459","https://security-tracker.debian.org/tracker/CVE-2013-6459"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2013-6459#Debian:14/ruby-will-paginate","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2013-6459"}],"summary":"Cross-site scripting (XSS) vulnerability in the will_paginate gem before 3.0.5 for Ruby allows remote attackers to inject arbitrary web script or HTML via vectors involving generated pagination links."}