{"action":"Upgrade rails to 2.3.14.1 or later.","affected":[{"fixed":"2.3.14.1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.3.14.1"],"id":"tcs_01M5NANFBPRPS874RVS1P2FV2W","modified_at":"2026-10-23T15:47:30.783939494Z","published_at":"2014-02-20T15:27:09.140Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-0081","https://security-tracker.debian.org/tracker/CVE-2014-0081"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-0081","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-0081"}],"summary":"Multiple cross-site scripting (XSS) vulnerabilities in actionview/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.17, 4.0.x before 4.0.3, and 4.1.x before 4.1.0.beta2 allow remote"}