{"action":"Upgrade node-qs to 2.2.4-1 or later.","affected":[{"fixed":"2.2.4-1","introduced":"0"}],"component":"node-qs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.2.4-1"],"id":"tcs_01M5NAPKWRF3R3NXZ2QWPWP7FV","modified_at":"2026-10-23T16:01:18.316198040Z","published_at":"2018-05-31T20:29:00.220Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-10064","https://security-tracker.debian.org/tracker/CVE-2014-10064"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-10064","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-10064"}],"summary":"The qs module before 1.0.0 does not have an option or default for specifying object depth and when parsing a string representing a deeply nested object will block the event loop for long periods of ti"}