{"action":"Upgrade requests to 2.3.0-1 or later.","affected":[{"fixed":"2.3.0-1","introduced":"0"}],"component":"requests","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.3.0-1"],"id":"tcs_01M5NAQ4ZSN4DEFVWARN08ZR6G","modified_at":"2026-10-23T15:47:25.689699704Z","published_at":"2014-10-15T14:55:05.400Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-1829","https://security-tracker.debian.org/tracker/CVE-2014-1829"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-1829#Debian:14/requests","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-1829"}],"summary":"Requests (aka python-requests) before 2.3.0 allows remote servers to obtain a netrc password by reading the Authorization header in a redirected request."}