{"action":"Upgrade patch to 2.7.6-r6 or later.","affected":[{"fixed":"2.7.6-r6","introduced":"0"}],"component":"patch","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.13","exploited":false,"fixed_versions":["2.7.6-r6"],"id":"tcs_01M5NAQF0XVG9BPNBNWMJ85XJ3","modified_at":"2026-10-23T17:17:55.252093594Z","published_at":"2019-08-16T04:15:09.860Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-20969","https://security.alpinelinux.org/vuln/CVE-2018-20969"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-20969#Alpine:v3.13/patch","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-20969"}],"summary":"do_ed_script in pch.c in GNU patch through 2.7.6 does not block strings beginning with a ! character. NOTE: this is the same commit as for CVE-2019-13638, but the ! syntax is specific to ed, and is un"}