{"action":"Upgrade imagemagick to 8:6.7.7.10+dfsg-1 or later.","affected":[{"fixed":"8:6.7.7.10+dfsg-1","introduced":"0"}],"component":"imagemagick","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["8:6.7.7.10+dfsg-1"],"id":"tcs_01M5NAQFCXW4SPNTSXE34PG2F1","modified_at":"2026-10-23T16:00:20.352026646Z","published_at":"2020-02-06T15:15:10.483Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-1958","https://security-tracker.debian.org/tracker/CVE-2014-1958"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-1958","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-1958"}],"summary":"Buffer overflow in the DecodePSDPixels function in coders/psd.c in ImageMagick before 6.8.8-5 might allow remote attackers to execute arbitrary code via a crafted PSD image, involving the L%06ld strin"}