{"action":"Upgrade libyaml-libyaml-perl to 0.41-5 or later.","affected":[{"fixed":"0.41-5","introduced":"0"}],"component":"libyaml-libyaml-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.41-5"],"id":"tcs_01M5NAQYVWDXKBQ76K96WYPXH0","modified_at":"2026-10-23T15:47:28.324067412Z","published_at":"2014-03-28T15:55:08.670Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-2525","https://security-tracker.debian.org/tracker/CVE-2014-2525"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-2525#Debian:14/libyaml-libyaml-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-2525"}],"summary":"Heap-based buffer overflow in the yaml_parser_scan_uri_escapes function in LibYAML before 0.1.6 allows context-dependent attackers to execute arbitrary code via a long sequence of percent-encoded char"}