{"action":"Upgrade ruby-rack-ssl to 1.3.2-4 or later.","affected":[{"fixed":"1.3.2-4","introduced":"0"}],"component":"ruby-rack-ssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.3.2-4"],"id":"tcs_01M5NAQZM2RWD0D2D6R49JD6CQ","modified_at":"2026-10-23T15:47:32.900236306Z","published_at":"2014-03-25T18:21:48.357Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-2538","https://security-tracker.debian.org/tracker/CVE-2014-2538"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-2538","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-2538"}],"summary":"Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be prope"}