{"action":"Upgrade fish to 2.1.1-1 or later.","affected":[{"fixed":"2.1.1-1","introduced":"0"}],"component":"fish","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.1.1-1"],"id":"tcs_01M5NARE3ZEXMD8ER1TDCKRC5F","modified_at":"2026-10-23T16:02:16.704442452Z","published_at":"2020-01-28T16:15:12.197Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-2914","https://security-tracker.debian.org/tracker/CVE-2014-2914"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-2914#Debian:14/fish","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-2914"}],"summary":"fish (aka fish-shell) 2.0.0 before 2.1.1 does not restrict access to the configuration service (aka fish_config), which allows remote attackers to execute arbitrary code via unspecified vectors, as de"}