{"action":"Upgrade ppp to 2.4.6-3 or later.","affected":[{"fixed":"2.4.6-3","introduced":"0"}],"component":"ppp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.4.6-3"],"id":"tcs_01M5NARJZDHMJBXJYSAH0507ZY","modified_at":"2026-10-23T15:47:25.363521295Z","published_at":"2014-11-15T21:59:00.117Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-3158","https://security-tracker.debian.org/tracker/CVE-2014-3158"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-3158","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-3158"}],"summary":"Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to \"access privileged options\" via a long word in an options file, which trigger"}