{"action":"Upgrade hiera to 1.3.4-1 or later.","affected":[{"fixed":"1.3.4-1","introduced":"0"}],"component":"hiera","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.3.4-1"],"id":"tcs_01M5NARQRT92A3T3DM0X41N0T2","modified_at":"2026-10-23T15:47:39.381721236Z","published_at":"2014-11-16T17:59:03.113Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-3248","https://security-tracker.debian.org/tracker/CVE-2014-3248"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-3248#Debian:14/hiera","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-3248"}],"summary":"Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5."}