{"action":"Upgrade mcollective to 2.6.0+dfsg-1 or later.","affected":[{"fixed":"2.6.0+dfsg-1","introduced":"0"}],"component":"mcollective","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.6.0+dfsg-1"],"id":"tcs_01M5NARR31CB32KBYE75913950","modified_at":"2026-10-23T15:47:25.939781995Z","published_at":"2014-08-12T23:55:03.643Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-3251","https://security-tracker.debian.org/tracker/CVE-2014-3251"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-3251","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-3251"}],"summary":"The MCollective aes_security plugin, as used in Puppet Enterprise before 3.3.0 and Mcollective before 2.5.3, does not properly validate new server certificates based on the CA certificate, which allow"}