{"action":"Upgrade file to 1:5.19-2 or later.","affected":[{"fixed":"1:5.19-2","introduced":"0"}],"component":"file","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1:5.19-2"],"id":"tcs_01M5NASNN0VWZKK82TP16CJ0MN","modified_at":"2026-10-23T15:47:35.658469248Z","published_at":"2014-08-23T01:55:01.977Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-3587","https://security-tracker.debian.org/tracker/CVE-2014-3587"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-3587#Debian:14/file","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-3587"}],"summary":"Integer overflow in the cdf_read_property_info function in cdf.c in file through 5.19, as used in the Fileinfo component in PHP before 5.4.32 and 5.5.x before 5.5.16, allows remote attackers to cause"}