{"action":"Upgrade pillow to 2.5.3-1 or later.","affected":[{"fixed":"2.5.3-1","introduced":"0"}],"component":"pillow","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.5.3-1"],"id":"tcs_01M5NASNREXRK46C9R4X79WS9C","modified_at":"2026-10-23T15:47:30.245336222Z","published_at":"2014-08-25T14:55:06.643Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-3589","https://security-tracker.debian.org/tracker/CVE-2014-3589"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-3589","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-3589"}],"summary":"PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size."}