{"action":"Upgrade libgcrypt20 to 1.6.3-2 or later.","affected":[{"fixed":"1.6.3-2","introduced":"0"}],"component":"libgcrypt20","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.6.3-2"],"id":"tcs_01M5NASP2EQ0X3T4P82VX2FV28","modified_at":"2026-10-23T16:00:34.545812448Z","published_at":"2019-11-29T22:15:11.703Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-3591","https://security-tracker.debian.org/tracker/CVE-2014-3591"],"severity":{"label":"medium","score":4.2},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-3591","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-3591"}],"summary":"Libgcrypt before 1.6.3 and GnuPG before 1.4.19 does not implement ciphertext blinding for Elgamal decryption, which allows physically proximate attackers to obtain the server's private key by determin"}