{"action":"Upgrade pydantic-ai-harness to 0.59.0 or later.","affected":[{"fixed":"0.59.0","introduced":"0"}],"component":"pydantic-ai-harness","cve_ids":["CVE-2026-114386"],"ecosystem":"PyPI","epss":0.00346,"exploited":false,"fixed_versions":["0.59.0"],"ghsa_id":"GHSA-3589-pxp7-3gj8","id":"tcs_01M5NASXSVE43CX4E8D4T89EEW","modified_at":"2026-10-23T21:00:05.311948379Z","published_at":"2026-10-21T15:42:26Z","references":["https://osv.dev/vulnerability/GHSA-3589-pxp7-3gj8","https://nvd.nist.gov/vuln/detail/CVE-2026-114386","https://github.com/pydantic/pydantic-ai/pull/10362","https://github.com/pydantic/pydantic-ai/commit/eb27b2b89fe76ae23ee9b6fc9eb4b227a4967949","https://github.com/pydantic/pydantic-ai","https://github.com/pydantic/pydantic-ai/blob/v2.58.0/src/pydantic_ai_harness/pydantic_ai_harness/code_mode/_toolset.py#L642-L680","https://github.com/pydantic/pydantic-ai/releases/tag/v2.59.0","https://pypi.org/project/pydantic-ai-harness/0.59.0","https://www.vulncheck.com/advisories/pydantic-ai-harness-before-0.59.0-codemode-tool-call-limit-bypass-via-run-code"],"severity":{"label":"medium","score":4.8},"sources":[{"source":"osv","source_id":"GHSA-3589-pxp7-3gj8","url":"https://osv.dev/vulnerability/GHSA-3589-pxp7-3gj8"}],"summary":"Pydantic AI Harness tool-call limit bypass in nested CodeMode calls"}