{"action":"Upgrade node-body-parser to 2.4.0+~1.19.6-1 or later.","affected":[{"fixed":"2.4.0+~1.19.6-1","introduced":"0"}],"component":"node-body-parser","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.4.0+~1.19.6-1"],"id":"tcs_01M5NATBHCC958TQBEN2YH9HJW","modified_at":"2026-10-26T08:00:08.541723590Z","published_at":"2026-10-22T15:17:04.763Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-111181","https://security-tracker.debian.org/tracker/CVE-2026-111181"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-111181#Debian:14/node-body-parser","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-111181"}],"summary":"body-parser is body parsing middleware for Node.js and Express. In versions before 1.20.9 and in versions from 2.0.0 before 2.4.0, a single request can crash any application using body-parser with def"}