{"action":"Upgrade ansible to 1.5.5+dfsg-1 or later.","affected":[{"fixed":"1.5.5+dfsg-1","introduced":"0"}],"component":"ansible","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.5.5+dfsg-1"],"id":"tcs_01M5NAV6HADF8NTB9TADQRJW24","modified_at":"2026-10-23T16:00:36.063504334Z","published_at":"2020-02-20T15:15:11.540Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-4657","https://security-tracker.debian.org/tracker/CVE-2014-4657"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-4657#Debian:14/ansible","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-4657"}],"summary":"The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions."}