{"action":"Upgrade ansible to 1.6.6+dfsg-1 or later.","affected":[{"fixed":"1.6.6+dfsg-1","introduced":"0"}],"component":"ansible","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.6.6+dfsg-1"],"id":"tcs_01M5NAV8JH2JVK3BAKPH1V7A1P","modified_at":"2026-10-23T16:01:50.902661666Z","published_at":"2020-02-20T03:15:10.717Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-4678","https://security-tracker.debian.org/tracker/CVE-2014-4678"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-4678#Debian:14/ansible","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-4678"}],"summary":"The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability ex"}