{"action":"Upgrade docker.io to 1.3.1~dfsg1-1 or later.","affected":[{"fixed":"1.3.1~dfsg1-1","introduced":"0"}],"component":"docker.io","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.3.1~dfsg1-1"],"id":"tcs_01M5NAW4DAYGZ46H6B487FQ0V7","modified_at":"2026-10-23T15:47:25.836987657Z","published_at":"2014-11-17T16:59:01.480Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-5277","https://security-tracker.debian.org/tracker/CVE-2014-5277"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-5277","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-5277"}],"summary":"Docker before 1.3.1 and docker-py before 0.5.3 fall back to HTTP when the HTTPS connection to the registry fails, which allows man-in-the-middle attackers to conduct downgrade attacks and obtain authe"}