{"action":"Upgrade libvncserver to 0.9.9+dfsg-6.1 or later.","affected":[{"fixed":"0.9.9+dfsg-6.1","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.9.9+dfsg-6.1"],"id":"tcs_01M5NAWBNM3DMN1KRFDGYJQQAB","modified_at":"2026-10-23T15:47:26.082313814Z","published_at":"2014-09-30T16:55:07.010Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-6051","https://security-tracker.debian.org/tracker/CVE-2014-6051"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-6051#Debian:13/libvncserver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-6051"}],"summary":"Integer overflow in the MallocFrameBuffer function in vncviewer.c in LibVNCServer 0.9.9 and earlier allows remote VNC servers to cause a denial of service (crash) and possibly execute arbitrary code v"}