{"action":"Upgrade node-send to 0.9.4-1 or later.","affected":[{"fixed":"0.9.4-1","introduced":"0"}],"component":"node-send","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.9.4-1"],"id":"tcs_01M5NAWMKNHY6REZXZXEBYT3SF","modified_at":"2026-10-23T15:47:29.208078496Z","published_at":"2014-10-08T17:55:05.123Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-6394","https://security-tracker.debian.org/tracker/CVE-2014-6394"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-6394#Debian:14/node-send","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-6394"}],"summary":"visionmedia send before 0.8.4 for Node.js uses a partial comparison for verifying whether a directory is within the document root, which allows remote attackers to access restricted directories, as de"}