{"action":"Upgrade node-qs to 2.2.4-1 or later.","affected":[{"fixed":"2.2.4-1","introduced":"0"}],"component":"node-qs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.2.4-1"],"id":"tcs_01M5NAX711JC0WRWJYSFTVQB2S","modified_at":"2026-10-23T15:47:25.671342722Z","published_at":"2014-10-19T01:55:21.560Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-7191","https://security-tracker.debian.org/tracker/CVE-2014-7191"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-7191#Debian:13/node-qs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-7191"}],"summary":"The qs module before 1.0.0 in Node.js does not call the compact function for array data, which allows remote attackers to cause a denial of service (memory consumption) by using a large index value to"}