{"action":"Upgrade rails to 2:4.1.8-1 or later.","affected":[{"fixed":"2:4.1.8-1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2:4.1.8-1"],"id":"tcs_01M5NAXGEH8JFH05BEJXA2MBT1","modified_at":"2026-10-23T15:47:38.658472727Z","published_at":"2014-11-08T11:55:02.977Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-7818","https://security-tracker.debian.org/tracker/CVE-2014-7818"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-7818","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-7818"}],"summary":"Directory traversal vulnerability in actionpack/lib/action_dispatch/middleware/static.rb in Action Pack in Ruby on Rails 3.x before 3.2.20, 4.0.x before 4.0.11, 4.1.x before 4.1.7, and 4.2.x before 4."}