{"action":"Upgrade smarty3 to 3.1.21-1 or later.","affected":[{"fixed":"3.1.21-1","introduced":"0"}],"component":"smarty3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.1.21-1"],"id":"tcs_01M5NAYRSDFHXD28Z1W6NAR2E2","modified_at":"2026-10-23T15:47:36.804542093Z","published_at":"2014-11-03T16:55:08.010Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-8350","https://security-tracker.debian.org/tracker/CVE-2014-8350"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-8350#Debian:14/smarty3","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-8350"}],"summary":"Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by \"{literal}<{/literal}script language=php>\" in a template."}