{"action":"Upgrade mercurial to 3.1.2-2 or later.","affected":[{"fixed":"3.1.2-2","introduced":"0"}],"component":"mercurial","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.1.2-2"],"id":"tcs_01M5NB0NEKCJ2JX9B4BGEJ6F54","modified_at":"2026-10-23T16:02:22.506559445Z","published_at":"2020-02-12T02:15:10.963Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-9390","https://security-tracker.debian.org/tracker/CVE-2014-9390"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-9390#Debian:14/mercurial","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-9390"}],"summary":"Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; m"}