{"action":"Upgrade zeromq3 to 4.0.5+dfsg-3 or later.","affected":[{"fixed":"4.0.5+dfsg-3","introduced":"0"}],"component":"zeromq3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.0.5+dfsg-3"],"id":"tcs_01M5NB1Y8YN2NV8W2XDJNWFNNN","modified_at":"2026-10-23T15:47:25.303224909Z","published_at":"2015-06-03T20:59:00.090Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2014-9721","https://security-tracker.debian.org/tracker/CVE-2014-9721"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2014-9721#Debian:14/zeromq3","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2014-9721"}],"summary":"libzmq before 4.0.6 and 4.1.x before 4.1.1 allows remote attackers to conduct downgrade attacks and bypass ZMTP v3 protocol security mechanisms via a ZMTP v2 or earlier header."}