{"action":"Upgrade glibc to 2.19-20 or later.","affected":[{"fixed":"2.19-20","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.19-20"],"id":"tcs_01M5NB4N95SMM5HHW8STAN4ARR","modified_at":"2026-09-09T06:47:28.496700444Z","published_at":"2015-09-28T20:59:00.093Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-1781","https://security-tracker.debian.org/tracker/CVE-2015-1781"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-1781#Debian:13/glibc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-1781"}],"summary":"Buffer overflow in the gethostbyname_r and other unspecified NSS functions in the GNU C Library (aka glibc or libc6) before 2.22 allows context-dependent attackers to cause a denial of service (crash)"}