{"action":"Upgrade swift to 2.2.0-2 or later.","affected":[{"fixed":"2.2.0-2","introduced":"0"}],"component":"swift","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.2.0-2"],"id":"tcs_01M5NB4Z73CQ3GEN3PRK91HP3N","modified_at":"2026-09-09T06:47:20.033686225Z","published_at":"2015-04-17T17:59:03.887Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2015-1856","https://security-tracker.debian.org/tracker/CVE-2015-1856"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2015-1856#Debian:13/swift","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2015-1856"}],"summary":"OpenStack Object Storage (Swift) before 2.3.0, when allow_version is configured, allows remote authenticated users to delete the latest version of an object by leveraging listing access to the x-versi"}